Support thread web app BMW i3

  • Kennst Du Dich ein wenig mit HTML uns JS aus, dann könntest Du in der ..\batt\index.html debug console.log Ausgaben hinzufügen also in etwa:

    hab einige an code hier jetzt rausgenommen. Das sieht man dann in den Entwicklertools vom Browser. Ala


    Die Entwicklertools sind unter Weitere Tools- Entwicklertools (bei FF und Opera ähnlich). Dann kann man die Problemecke hoffentlich einkreisen. Wenn man die Seite lädt sollten die Ausgaben dann kommen. Wobei es zu 99% an irgendwelchen Settings/umgebungsparametern liegt - aber bugs will ich nicht auschließen.


    Note: Du hast eine PM mit einer angepassten index.html

    PV 18,2kWp - BHKW EcoPower 1.0, 30kWh LiON Sunny Island System

    BMW i3 60Ah (Verbrauch ca. 13,8kWh/100km; SW: I001-16-07-506)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Olaf Krause ()

  • Dann liegt es zu 99% im PHP Teil (api/index.php) der das Load event auslösen müsste.

    Sorry das ich nochmals nachfrage: definitiv keine PHP fehler? Fehler werden auch in das Logfile das Du angeschaut hast protokolliert (nicht zufällig in ein anderes?)

    Ansonsten muss ich mir mal überlegen ob/wie ich in solchen Fällen ohne Zugriff auf den Webserver supporten kann.

    PV 18,2kWp - BHKW EcoPower 1.0, 30kWh LiON Sunny Island System

    BMW i3 60Ah (Verbrauch ca. 13,8kWh/100km; SW: I001-16-07-506)

  • Mein Problem ist, dass er noch nicht einmal versucht den PHP-Teil zu starten.

    Ausgeschlossen ist eine Fehlkonfiguration durch mich keineswegs, aber das erste damalige script läuft auch ohne Probleme.

    Andere - provozierte - Fehler in PHP stehen dann in der PHP-Logdatei, daher glaube ich schon, dass es keine gibt.

  • Ich bin jetzt weiter gekommen.

    Wenn ich in der htaccess

    Code
    1. # Strip spaces
    2. <IfModule mod_substitute.c>
    3. AddOutputFilterByType SUBSTITUTE text/html
    4. Substitute s/(\n|\t|\s\s+)//q
    5. </IfModule>

    auskommentiere, dann versucht er wenigstens ./api/index.php aufzurufen, bekommt aber einen error 403 - forbidden.



    Code
    1. # Security headers
    2. <IfModule mod_headers.c>
    3. <IfModule mod_setenvif.c>
    4. SetEnvIf Request_URI ^/$ is_html=1
    5. Header set X-Content-Type-Options "nosniff" env=is_html
    6. Header set X-XSS-Protection "1; mode=block" env=is_html
    7. Header append X-Frame-Options "SAMEORIGIN" env=is_html
    8. Header set Content-Security-Policy "default-src 'none'; script-src 'self' 'unsafe-inline' 'unsafe-eval'; font-src 'self'; img-src 'self'; style-src 'unsafe-inline'; connect-src 'self'" env=is_html
    9. </IfModule>
    10. </IfModule>

    Wenn dies in der htaccess bleibt, dann bekomme ich folgende Fehler:

    (index):21 Refused to load the stylesheet 'https://xyz.de/batterieapp_style.css' because it violates the following Content Security Policy directive: "style-src 'unsafe-inline'".

    (index):1 Refused to load the font 'data:application/font-woff;base64,d09GRgABAAAAAJPsABIAAAABOnAAAQAAAACRvAAAAjAAAAarAAAAAAAAAABHREVGAACH3AAAAB8AAAAgAZkABUdQT1MAAIf8AAAJYgAAIEoSJsZLR1NVQgAAkWAAAABaAAAAgOq9Lj5PUy8yAAACDAAAAE4AAABgW/hYh2NtYXAAABMoAAAChQAAA66C/ZF+Y3Z0IAAAF7gAAABOAAAATgQWCyNmcGdtAAAVsAAAAQIAAAFzBlmcN2dhc3AAAIfQAAAADAAAAAwADgAOZ2x5ZgAAGuQAAGObAADUaN4bMjBoZG14AAAFUAAADdcAAB+otSCvTGhlYWQAAAGUAAAANAAAADb+7d+UaGhlYQAAAcgAAAAhAAAAJAgKBL1obXR4AAACXAAAAvEAAAWMbaNf4WxvY2EAABgIAAAC2gAAAtoqVPTibWF4cAAAAewAAAAgAAAAIAOPBQxuYW1lAAB+gAAABLgAA...mGuNJyKtWKCpXDV3d/uWTS477WykdO175nFoNy1wgH8y/Qt28QjNUGrR9A10Dz1+3/5oez68m2uTmP4bvuQLIBlPZQaTOEIInimt5cOG/FvvMYApHCda9azTj1edR4cgnlPGtbEB46oxUwNVAtaSjVTgGNdn701lbLydvqinla1tTfghWHxoPX0BFj/l9grtvfYjX5R4w7tNKNALdoj8QysINFlKgoomEe8I4Gd7BH3yMqGAggUxxmzDF8rQktVa2aR6n3WeEUPvPxdJqawIzzm84a7TCGDRmkHudU5JMTqBBMi4xyj8IR6NcvdeKqIgsjtPO8QJCe5sJpTRXJbw2WBUdXWWHG4d5086abU7p5LJdiXO7Ec3k1f8HZ1TlkaboI6blIn1dM/DyIInkoXHjLOEpmf5RfNO1CwrYiftWWTH7cJIM/ES8qNIS+EbSecRF7BIsHWg556RJQUJHAGb1vOyscF9UIz8VF8tB8PrTx9A1AJ3wy3zzlLzZsSzQ=' because it violates the following Content Security Policy directive: "font-src 'self'".

  • OK - das mit der htaccess ist eine typische Stolperfalle - hatte das einmal bei mir erfolgreich getestet aber je nach Umgebung muss es angepasst werden.

    Da bin ich auch nicht der Experte, da ich unter IIS hoste ... bzgl. 403 - prüfe mal HTTP_REFERER settings.

    PV 18,2kWp - BHKW EcoPower 1.0, 30kWh LiON Sunny Island System

    BMW i3 60Ah (Verbrauch ca. 13,8kWh/100km; SW: I001-16-07-506)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Olaf Krause ()

  • Nein - ohne .htaccess gelten ja auch Sicherheitseinstellungen allerdings dann vom Apache selber - daher macht Deine Frage nach wer hosted sonst dort sinn, aber ich kenne keinen (zumindest nicht bewusst).

    PV 18,2kWp - BHKW EcoPower 1.0, 30kWh LiON Sunny Island System

    BMW i3 60Ah (Verbrauch ca. 13,8kWh/100km; SW: I001-16-07-506)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Olaf Krause ()

  • Hallo Olaf,

    endlich habe ich´s geschafft Eure WebApp auch bei mir zum Laufen zu bekommen. Seit der letzten eRUDA war ich am basteln und habe versucht mich in das Thema einzulesen, obwohl ich von PHP/Apache usw. keine Ahnung habe.


    Eine Frage zu Deiner letzten Version "BattV3": Hierin wird nunmehr auch der HV_PERCENT Wert mit ausgelesen. Was besagt dieser Wert genau? % von was?

    % der im i3 verbauten Brutto-Akkukapazität?

    % der dem Benutzer zur Verfügung gestellte Nettokapazität gegenüber dem Neuzustand? D.h. so eine Art Maß für die Alterung des Akkus?


    Vielen, vielen Dank an Eure umfangreichen Hilfstellungen hier und im GoingElectric!!! Ihr seit echt klasse...


    Gruss Ralph(edfgler)

  • Hi Ralph, was der Wert genau besagt weiss vermutlich nur BMW - die Vermutung liegt Nahe, dass der Wert den Gesamtgesundheitszustand/Kapa im Verhältnis zur ursprünglichen wiedergibt.


    Notreallyme hat hier mit seinen >>200tkm ja etliche Daten gesammelt. Wenn auch eher für den 94er Akku:

    https://www.goingelectric.de/f…bei-94er-akku-t27198.html

    PV 18,2kWp - BHKW EcoPower 1.0, 30kWh LiON Sunny Island System

    BMW i3 60Ah (Verbrauch ca. 13,8kWh/100km; SW: I001-16-07-506)