Posts by Powersup

    Ich bin jetzt weiter gekommen.

    Wenn ich in der htaccess

    Code
    1. # Strip spaces
    2. <IfModule mod_substitute.c>
    3. AddOutputFilterByType SUBSTITUTE text/html
    4. Substitute s/(\n|\t|\s\s+)//q
    5. </IfModule>

    auskommentiere, dann versucht er wenigstens ./api/index.php aufzurufen, bekommt aber einen error 403 - forbidden.



    Code
    1. # Security headers
    2. <IfModule mod_headers.c>
    3. <IfModule mod_setenvif.c>
    4. SetEnvIf Request_URI ^/$ is_html=1
    5. Header set X-Content-Type-Options "nosniff" env=is_html
    6. Header set X-XSS-Protection "1; mode=block" env=is_html
    7. Header append X-Frame-Options "SAMEORIGIN" env=is_html
    8. Header set Content-Security-Policy "default-src 'none'; script-src 'self' 'unsafe-inline' 'unsafe-eval'; font-src 'self'; img-src 'self'; style-src 'unsafe-inline'; connect-src 'self'" env=is_html
    9. </IfModule>
    10. </IfModule>

    Wenn dies in der htaccess bleibt, dann bekomme ich folgende Fehler:

    (index):21 Refused to load the stylesheet 'https://xyz.de/batterieapp_style.css' because it violates the following Content Security Policy directive: "style-src 'unsafe-inline'".

    (index):1 Refused to load the font 'data:application/font-woff;base64,d09GRgABAAAAAJPsABIAAAABOnAAAQAAAACRvAAAAjAAAAarAAAAAAAAAABHREVGAACH3AAAAB8AAAAgAZkABUdQT1MAAIf8AAAJYgAAIEoSJsZLR1NVQgAAkWAAAABaAAAAgOq9Lj5PUy8yAAACDAAAAE4AAABgW/hYh2NtYXAAABMoAAAChQAAA66C/ZF+Y3Z0IAAAF7gAAABOAAAATgQWCyNmcGdtAAAVsAAAAQIAAAFzBlmcN2dhc3AAAIfQAAAADAAAAAwADgAOZ2x5ZgAAGuQAAGObAADUaN4bMjBoZG14AAAFUAAADdcAAB+otSCvTGhlYWQAAAGUAAAANAAAADb+7d+UaGhlYQAAAcgAAAAhAAAAJAgKBL1obXR4AAACXAAAAvEAAAWMbaNf4WxvY2EAABgIAAAC2gAAAtoqVPTibWF4cAAAAewAAAAgAAAAIAOPBQxuYW1lAAB+gAAABLgAA...mGuNJyKtWKCpXDV3d/uWTS477WykdO175nFoNy1wgH8y/Qt28QjNUGrR9A10Dz1+3/5oez68m2uTmP4bvuQLIBlPZQaTOEIInimt5cOG/FvvMYApHCda9azTj1edR4cgnlPGtbEB46oxUwNVAtaSjVTgGNdn701lbLydvqinla1tTfghWHxoPX0BFj/l9grtvfYjX5R4w7tNKNALdoj8QysINFlKgoomEe8I4Gd7BH3yMqGAggUxxmzDF8rQktVa2aR6n3WeEUPvPxdJqawIzzm84a7TCGDRmkHudU5JMTqBBMi4xyj8IR6NcvdeKqIgsjtPO8QJCe5sJpTRXJbw2WBUdXWWHG4d5086abU7p5LJdiXO7Ec3k1f8HZ1TlkaboI6blIn1dM/DyIInkoXHjLOEpmf5RfNO1CwrYiftWWTH7cJIM/ES8qNIS+EbSecRF7BIsHWg556RJQUJHAGb1vOyscF9UIz8VF8tB8PrTx9A1AJ3wy3zzlLzZsSzQ=' because it violates the following Content Security Policy directive: "font-src 'self'".

    Mein Problem ist, dass er noch nicht einmal versucht den PHP-Teil zu starten.

    Ausgeschlossen ist eine Fehlkonfiguration durch mich keineswegs, aber das erste damalige script läuft auch ohne Probleme.

    Andere - provozierte - Fehler in PHP stehen dann in der PHP-Logdatei, daher glaube ich schon, dass es keine gibt.

    Guten Morgen Olaf,

    großes Lob für deinen Einsatz. Ich probiere gerade deine WebApp zum laufen zu bekommen, komme aber leider nicht über "Updating" hinaus. Das Ganze läuft auf einem apache mit PHP 5.6.38, testweise auch mit PHP 7.0, 7.1 bis 7.2.3 probiert.

    Leider gibt es bereits Probleme mit deiner Installanleitung. Ich fand nur V2 und V3, aber bereits die Datei appstats.txt wird bei mir nicht erstellt und daher konnte ich sie gar nicht editieren. Dann habe ich eine eigene in /data erstellt.

    Egal ob mit deiner Muster .htaccess oder ohne komme ich über updateing nicht hinaus.

    Hast du noch eine Idee?